Intermittent nonprofit search errors
Incident Report for Bright Funds
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 22:47 PDT
Identified
Our nonprofit search provider is experiencing degraded performance. This may result in intermittent nonprofit search errors on Bright Funds. If your search fails please retry after a short wait and it should go through. Please contact support@brightfunds.org or user our live chat widget if you are unable to complete a search.
Posted Apr 01, 2021 - 16:14 PDT
This incident affected: Website.